Jump to content

Error generate URL. Bad parameters (#8)


evolver
 Share

Recommended Posts

Я использую два индентичных компьютера с Windows7 и KartinaTV 2.64, настроенных на один и тот же аккаунт.

 

На одном из них я поменял конфигурацию hotkey и перезапустил приложение. Теперь на это компьютере при попытке получить URL для передачи VLC плееру, REST API стабильно возвращает "Error generate URL. Bad parameters (#8)".

 

Я посмотрел на HTTP POST request, который посылают оба компьютера (работающий и "поломавшийся"). У обоих они идентичные, но одному приходит ответ с URL, а другому - упомянутая выше ошибка.

 

Очевидно, что каким-то образом сервер по-разному реагирует на запросы обеих машин. На основании чего он может различать их? Может ли быть что-то в предшествующих запросах перед get_url, что вызвало бы ошибку #8?

 

Хотелось бы услышать мнение людей, знающих серверную часть API, относительно ошибки #8.

 

Заранее всем спасибо!

post-4503-0-87682100-1400431990_thumb.png

Link to comment
Share on other sites

Я строил дебаг билд: http://rt.coujo.de/Kartina.TV-2.68-20140519-TRACES-win-x86-setup.zip
Было бы хорошо, если вы это установливаете на компы. Когда ошибка будет, мне надо лог.

Какой у вас есть таймшифт, какой битрейт? Это на компах одинакого?

Link to comment
Share on other sites

Большое спасибо. Я вечером попробую с логами и пришлю их потом.

 

Тайм-шифт и бит-рейт одинаковые.

Сам запрос тоже одинаковый: HTTP POST с cid и gmt полями.

Link to comment
Share on other sites

Я сглазил, похоже. Теперь компьютер 2 с версией 2.68 начал опять давать ошибку после того, как я поменял hotkey на компьютере 1!

 

Как в версии с трейсами посмотреть лог?

Link to comment
Share on other sites

Нашел лог! Прилагаю к сообщению.

 

У меня еще есть перехваты траффика из Wireshark и Fiddler


Кстати, вот такой ответ прилетает от сервера

{"error":{"message":"Error generate URL. Bad parameters","code":8},"servertime":1401147619}
Link to comment
Share on other sites

Проблема была в том что время на компе не подходил (1 целый день). 

 

Я все же строил новый билд где время на компе больше не должно играть роль: http://rt.coujo.de/Kartina.TV-2.69B8-TRACES-20140528-win-x86-setup.zip
Link to comment
Share on other sites

Да, каким-то неведомым образом после недавней перестановки системы часы на компьютере шли на сутки вперед. Время было верно, но вот дата была неправильная. Из-за этого приложение запрашивало стрим с ошибкой на сутки и сервер совершенно правомерено ругался.

 

Любопытно, что встроенная синхронизация времени в Windows не корректировала дату и говорила, что время было успешно синхронизровано. Может оно действительно только *время* и синхронизирует. Но это уже вопрос не для этого форума :)

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...